Come correggere l’errore irreversibile di RevSlider nella dashboard dopo l’aggiornamento a PHP7?

0
erroreversionephpv
errore versione php v7 1

Si può verificare con il nostro sito creato con CMS WordPress, che o dopo un migrazione su server con già installata la versione php 7 o semplicemente aggiornano la versione spesso si verifica il seguente errore:

www.tuosito.com/wp-content/plugins/revslider/includes/framework/base-admin.class.php

una vera e propria incompatibilità con questa versione, il plugin in questione è: RevSlider in questo caso, ma si può verificare anche con altri plugin magari non troppo recenti, possiamo risolvere questo problema, andiamo nella cartella seguente:

wp-content/plugins/revslider/includes/framework/base-admin.class.php

andiamo alla riga 21 a sostituire la seguente:

private static $arrMetaBoxes = ''; 

con questa:

private static $arrMetaBoxes = array();   

aggiorniamo il tutto e potremmo cosi utilizzare benissimo la versione PHP aggiornata.

tutto qua!.

PS: se ti è piaciuto questo articolo, regalami un tuo mi piace.
Articolo precedenteAvviare Windows 8 in modalità Desktop
Articolo successivoOrario PC sballato: perché il computer non mantiene l’ora?
Web designer e webmaster freelance. Appassionato di comunicazione e nuove tecnologie, sviluppo e gestisco siti web vetrina, e-commerce, magazine dal 1995. Studio l’usabilità dei siti per una migliore fruizione dei contenuti da parte degli utenti.

LASCIA UN COMMENTO

Per favore inserisci il tuo commento!
Per favore inserisci il tuo nome qui